Certificado SSL / TLS de Let's Encrypt con CG-NAT

Buenas a ver si alguien me puede dar una mano: Tengo mi proveedor de internet con CGNAT ya se que lo de abrir puertos imposible. con lo cual letsencript nunca lo pude utilizar. ahora tengo VPN contratado y conectado en el Nas AS6204T la teoría es que abro si podría utilizar lestsencript.
pero nada me sigue saliendo:

xxx.myasustor.com no es válido. Por favor, asegúrese de que su nombre de dominio puede conectarse correctamente a través del puerto 80. (Ref. 5056)

y el ez-connect ya no marea los puertos tampoco me sale lo siguiente:

El enrutador no es compatible o no tiene UPnP/NAT-PMP activado

ya no se que pensar si alguien me pudiera dar una mano lo agradecería.

Buenos días,

Hola FiRu, bienvenido al foro. Me temo que la configuración y el uso del certificado SSL de Let’s Encrypt requiere forzosamente la redirección del puerto correspondiente y esto no es posible con CG-NAT, ni siquiera mediante una VPN. Es más, la conexión VPN aún dificulta más la mencionada redirección, dado que los proveedores de dicho servicio no suelen facilitar esa clase de redireccionamiento de entrada. La única manera que permitirá esto, será solicitar la baja de dicho servicio en tu proveedor de Internet.

Un cordial saludo,

Rubén Rodríguez

Hola.

Es cierto que hay determinados operadores que funcionan bajo CG-NAT pero tienes la opción con ellos de eliminarlo, consúltalo. En muchos de ellos conlleva un suplemento de 1€ en el coste de la fibra.

Un saludo.

1 me gusta

Que tal FiRu, no se de que pais sos, yo tuve el mismo problema con Telecentro en argentina y luego de varios llamados y no querer cambiar eso.
Estuve leyendo y vi que mucha gente cuando les decia a soporte que tenia camaras ip para instalar y que no le andaba, les sacaban el nateo.
Y asi fue, llame le dije lo de las camaras y me sacaron el nateo…ya recibo la ip publica.
Saludos y espero te sirva.